ADA4627 trailing edge delay after saturation

Hi, all.

I bumped into a very strange behavior of ADA4627 op amp, and will be very grateful if you give me any tiny insight into what's happening. Right now I even don't know where to look for solution.

Here is our scheme, as it appears right at the moment:

The goal is to measure currents of several photodiodes. PDs are unbiased, currents lie in the range from tens of nA to several mkA and look like pulses with fronts of 7-10 mks and duration 20-50 mks (we can tune the duration, actually, but try to lower it to increases the speed of measurements). The desired measuring frequency is 50-100 kHz and noise of the order of several nA. We took EVAL-AD76MUXEDZ board with AD7699 ADC. The board allready had input amplifiers ADA4841-1, but those had too large input leakage current and we replaced them with ADA4627.

At moderate currents all works well. The mystic things come when upper level of input current pulse drives the amplifier into saturation. The trailing edge of pulse at the amplifier output suddenly jumps about 20 mks later than it was at lower current level. It happens for at least 4 of our PDs. And it does not happen with the very same PDs when they are loaded on to AD8605 op amp. But ADA4627 is preferrable, since it permits larger dynamic range at the same level of noise (25 V output vs 5 V).

Now questions.

1. What the heck is going on? I don't know how to find any piece of info about this effect because I just don't know how to call it.

2. There are some components left from the initial board scheme that we don't really need - R2, R3 and C3. Can they be somehow involved?

3. We are going to increase the ADA4627 positive power supply to +24 V to achieve maximum dynamic range. Will that help with this effect? Will it at least shift the effect to higher currents?

4. Just when writing this post I realized we have only +5 V ADC supply. As its manual tells, AD7699 has protective diodes that open when input voltage exceeds supply rail. Can that be the reason?

  • Thanks for explanation, Harry.

    Yes, of course, this type of question requires scope pictures. But at the moment I got only one scope and it is old enough to have no connectivity to PC. I had to take photos of its screen with a cell phone... looks awful, but, nonetheless, useful.

    Pulse fronts at low currents (no saturation):

    In the left bottom corner you can see a sync pulse, which goes about 18 mks before each transition of the PD's current.

    The same at high currents:

    The trailing front is 15-20 mks later its estimated moment.

    Scope shows that saturation level is about 5 V. That made me believe that the reason is the AD7699 overload. I lowered the positive supply of ADA4627 to 5 V (the same rail the AD7699 uses), but the effect was pretty much the same. The only difference was that saturation level lowered to about 3 V.

  • Yes, we are going to use -5..+24 supply on ADA4627 (asymmetrical, because PD produces current in only one direction), but I'l try it only on thursday. I'l post all results here as soon as I get them.

  • Thursday happen to become tuesday. Sorry.

    With +24 V supply the delay ceased to about 8 mks.

    Low currents (no saturation):

    Saturation:

    Well, that's kinda a solution to my problem.