Problem of amplitude with LTC6261 amplifier (inexplicable attenuation of input signal)

Hello,

I am using the LTC6261 amplifier to design a second order low pass filter. My low pass filter has a 5 Hz cutoff frequency. Here is the scheme.

So as you can see I have two resistors of 220 k and two capacitors : one 100 nF and another of 220 nF. The output of the amplifier and so the filter goes to the ADC input of a MCU. My problem is that I have an attenuation of the input signal of the filter at the output. I mean when I put for example a 1 Hz sine wave at the filter input with a 2 Vpp voltage, and at the output I have only 1.8 Vpp, which is incorrect since I have a 5 Hz cutoff frequency. Also, to be sure that the problem doesn't come from the filter, I have retired the capacitors and just kept the resistors, which finally give us a simple buffer. Despite that I wasn't able to have the same signal at the output, I still had 200 mV attenuation (1.8 Vpp instead of 2Vpp). Also I was wondering if it's not the impedance of the ADC that is too important that is the cause of the problem. So I have disconnected the amplifier output and the ADC and still the same attenuation. I have tried everything I also soldered a new amplifier and still nothing. I really don't know from where this attenuation comes. I also checked the datasheet but I don't know if I missed something that could explain this. Any help would be appreciated.

Thank you very much,

Best regards,

Mike

  • 0
    •  Analog Employees 
    on Feb 12, 2020 11:51 PM 8 months ago

    Hello Mike,

    What is the input and output waveforms like? What's the DC offset of the input waveform? What's supplying the voltage at the input? Function Generator?

    One issue I see here is that the bias current of the amplifier is rated at maximum of about 100nA. With 440kohms (220k+200k) at the input, that would shift the DC level and potentially cause the output to clip. If you can provide the waveforms, that would be fantastic.

    You can also reach me at Kaung.Win@analog.com

    Kaung

  • Hi Kaung,

    Thank you for your reply.

    The input is a 2 Hz sine wave with a 2Vpp amplitude and an offset of 1 V. Yes indeed, the input comes from a function generator. Here are the waveforms I have:

    1) On the first one here we have in yellow the input signal which is a 2 Hz sine wave with 2Vpp and 1 V offset. And in blue the output. And as you can see a 160 mV attenuation. We have 2.08 V max for the input and only 1.92 for the output.

    2) The second one here is the same capture as above but with a zoom. 

    3) Finally this one is for a 3 Hz sine wave signal with 2Vpp and 1 V offset. As you said here for a 3 Hz signal at input I have the DC level that is shifted as you can see with the below cursor : 120 mV. And the Vpp amplitude is only 1.76 V now. 

    I hope this would help. I am really confused about this, I really don't know how to resolve it, I have really tried everything.

    Thank you very much,

    Best regards,

    Mike

  • Hello Kaung,

    I just would like to add some precisions about the last post. If the problem comes from the input bias current which has a maximum value of 100 nA then we should have with an equivalent resistor of 400 kohms (220k + 200k) a drop voltage of 44 mV. But in my case I have an attenuation of 160 mV as you saw with the waveforms. Could we then consider that it's really the input bias current the cause ?

    Thank you,

    Best regards,

    Mike

  • Hi Mike,

    Don't forget that:

    First, the common-mode input resistance of this amplifier is 10MΩ typical, which forms a voltage divider together with two resistors at the input.

    Second, the input resistance of the oscilloscope creates a voltage divider together with these resistors.

    Consider these factors and review the results.

    Could we then consider that it's really the input bias current the cause ?

    You have the circuit and measuring instruments, not us, so it will be much better if you measure it. Simply ground the circuit input and measure the output voltage. Then we can discuss it.

    Regards,

    Kirill

  • Hi Kirill,

    Thank you for your reply. 

    the common-mode input resistance of this amplifier is 10MΩ typical, which forms a voltage divider together with two resistors at the input.

    The common mode input resistance is the resistance between the + and - input pins. How then it could form a voltage divider with two resistors ? I mean we have the voltage source then the two resistors which forms an equivalent resistor and then the common mode input resistance, but the last one is between the two input pins so how it could be a voltage divider (the common mode resistance is not connected to gnd) ?

    Thank you,

    Regards,

    Mike