ethernet usb not recognized with adalm pluto

Hi,

I have an Ethernet usb adapter like this:

https://www.amazon.es/AmazonBasics-Adaptador-red-LAN-Ethernet/dp/B00M77HLII/ref=sr_1_29?ie=UTF8&qid=1525853686&sr=8-29&keywords=usb+ethernet

but for some reason when I plug this device to the pluto usb througth and OTG cable with an usb power connected to the other usb for powering the pluto the ethernet adapter doesn't turn on(green led is OFF) and do nothing.

I don't know what to do because with this device connected to usb I can't go inside pluto to see if device is recognized or not.

the adapter is working correctly with usb 2.0 in a windows machine.

I tried to use a usb hub for powering the adapter with an external power source but nothing.

Any ideas?.

thanks.

Parents
  • hi ,

    I've repeat the previous steps with another otg cable and now I'm able to see the ethernet chipset running dmesg:

    usbcore: registered new interface driver ax88179_178a

    and the device is in the compatible list.

    but still don't see the:

    hub 1-0:1.0: USB hub found
    hub 1-0:1.0: 1 port detected

    I've tried the usb otg cable and the usb hub for power supply with an windows tablet and it works so the calbe seems to be ok

    also I tried another wifi dongle (rtl18187) but device is recognized in device list but the wifi led is off and seems is not operating.

    when you say:

    "if you are in USB HOST mode"

    what does it means?.

Reply
  • hi ,

    I've repeat the previous steps with another otg cable and now I'm able to see the ethernet chipset running dmesg:

    usbcore: registered new interface driver ax88179_178a

    and the device is in the compatible list.

    but still don't see the:

    hub 1-0:1.0: USB hub found
    hub 1-0:1.0: 1 port detected

    I've tried the usb otg cable and the usb hub for power supply with an windows tablet and it works so the calbe seems to be ok

    also I tried another wifi dongle (rtl18187) but device is recognized in device list but the wifi led is off and seems is not operating.

    when you say:

    "if you are in USB HOST mode"

    what does it means?.

Children
No Data