Post Go back to editing

Pluto Sdr Waveform phase and amplitude Drift

Category: Hardware
Product Number: AD9363

i'm using pluto sdr, doing bpsk and sending I samples directly from the block memory. In loop back I'm receiving exactly same waveform but on 2 boards the phase and amplitude is changing. i also tried to send QPSk fsk etc but still same. Any solution ?

  • Hi,  I am currently looking into your matter. I appreciate your understanding as we work towards a resolution.

  • Many people are facing this problem but no one have the solution.

  • Can you explain your setup? You said you are using 2x plutos?

    -Travis

  • Hi. I am trying to transmit bpsk samples from PL. As I transmit the samples i am noticing the amplitude modulation on my samples that shifts my samples to 180 (like the waveform is continually multiplied with positive and negative amplitude of the sine wave). I have tried to inspect the probem and here are the some of results.
    1. The problem does not arises when i try to loop back the tx and rx on the same board with my custom samples or with any other waveform.
    2. The amplitude modulation is observed only the waveform is transmitted to another board.
    3. The DDS generated sine wave when recieved on same board does not have any amplitude modulation but when transmitted to another board there is a minor amplitude modulation on the samples when large number of samples are observed.
    4. I have tried changing the TX and RX frequency of the same board (to avoid VCO pulling) but that has no effect.
    5. I have tried turning off the quadrature tracking and other 2 trackings with different possibilites but that has no effect.