Post Go back to editing

UNABLE TO USE THE FMCOMM BLOCKS IN GNU RADIO 3.10.5

Category: Software
Product Number: SN:00981 S21-0549

I HAVE TRIED ALL POSSIBLE INSTALLATION PROCEDURES BUT STILL GETTING THE IIO ERROR CONSISTENTLY. I HAVE USED THE FOLLOWING LINK TO INSTALL DEPENDENCIES AND THEN INSTALLED GNU RADIO 3.10.5.

https://wiki.analog.com/resources/tools-software/linux-software/gnuradio#download_and_build_libiio

AFTER THE INSTALLATION I AM FACING THE FOLLOWING ERROR:

<<< Welcome to GNU Radio Companion 3.10.5.0 >>>

Block paths:
/usr/share/gnuradio/grc/blocks

Loading: "/home/cipl/tyest1.grc"
>>> Done

Generating: '/home/cipl/tyest1.py'

Executing: /usr/bin/python3 -u /home/cipl/tyest1.py

Traceback (most recent call last):
  File "/home/cipl/tyest1.py", line 169, in <module>
    main()
  File "/home/cipl/tyest1.py", line 147, in main
    tb = top_block_cls()
  File "/home/cipl/tyest1.py", line 99, in __init__
    self.iio_fmcomms2_source_0 = iio.fmcomms2_source_fc32('ip:192.168.1.173', [True, True, False, False], 32768)
AttributeError: module 'gnuradio.iio' has no attribute 'fmcomms2_source_fc32'

>>> Done (return code 1)

PLEASE HELP WITH THE INSTALLATION PROCESS .

THANK YOU

Parents
  • How did you install gnuradio ? Did you build it from source or via package manager ? What OS are you using ? Did you have an older version of gnuradio prior to 3.10.5 installed on this PC ?

  • Hi,

    I installed my GNURadio from this link ( https://wiki.gnuradio.org/index.php/InstallingGR ) for windows with Radioconda installer.

    I use Windows 10 64-bit version.

    I had previous version. I uninstalled it first than installed 3.10.5 version.

    My error is something like this:

                                                    line 199, in __init__
                                                    self.iio_pluto_source_0 = iio.fmcomms2_source_fc32('local:' if 'local:' else iio.get_pluto_uri(), [True, True], 32768)
                                                    AttributeError: module 'gnuradio.iio' has no attribute 'fmcomms2_source_fc32'

    Thanks for support.

    Best Regards,

    Bora Kilerci

  • Hi again,

    I deleted anything related about GNURadio and installed 3.10.4 again via Radioconda.

    It works, however TX and RX doesn't work simultaneously.

    I created a fm receiver, works fine.

    Then created and transmitter, works fine.

    However, not at the same time. Error code under below

    File "D:\Yazilim\Amator_telsiz\SDR\GNU_Radio\Radar.py", line 212, in __init__ 

    self.iio_pluto_sink_0 = iio.fmcomms2_sink_fc32('' if '' else iio.get_pluto_uri(), [True, True], 32768, False)  #  I tried any methode, ip:192.168.2.1.local etc. nothing works when

    both tx and rx need to be work

    RuntimeError: No Pluto device found                =============>>>>>>>>      # I can work with other SDR softwares, like SDR Angel, SDR Console etc.

    OOOOOOOOOOOOO                                       =============>>>>>>>>     # The "counter" i would say when the code started by me it starts printing "O" 's in this line.

    QT GUI doesn't show up but code looks started

    I'm trying to make a basic Radar project.

    Thx for now.

    Best Regards,

    Bora Kilerci

Reply
  • Hi again,

    I deleted anything related about GNURadio and installed 3.10.4 again via Radioconda.

    It works, however TX and RX doesn't work simultaneously.

    I created a fm receiver, works fine.

    Then created and transmitter, works fine.

    However, not at the same time. Error code under below

    File "D:\Yazilim\Amator_telsiz\SDR\GNU_Radio\Radar.py", line 212, in __init__ 

    self.iio_pluto_sink_0 = iio.fmcomms2_sink_fc32('' if '' else iio.get_pluto_uri(), [True, True], 32768, False)  #  I tried any methode, ip:192.168.2.1.local etc. nothing works when

    both tx and rx need to be work

    RuntimeError: No Pluto device found                =============>>>>>>>>      # I can work with other SDR softwares, like SDR Angel, SDR Console etc.

    OOOOOOOOOOOOO                                       =============>>>>>>>>     # The "counter" i would say when the code started by me it starts printing "O" 's in this line.

    QT GUI doesn't show up but code looks started

    I'm trying to make a basic Radar project.

    Thx for now.

    Best Regards,

    Bora Kilerci

Children
No Data