libsmu on Mac syetems

I'm trying to install libsmu and alice on a Macbook. I followed the instruction from here https://github.com/analogdevicesinc/libsmu for mac.

But in the compilation step, 'make' command, I received the error "No module named Cython.build" that has been searched in python2.7/site-packages, I guess.

So I added python3.7/site-packages address to my $PATH. After this change, for 'make' command I receive  "setuptools no longer work on python2" error.

First error:

Second error: