Post Go back to editing

ADALM Pluto SDR MATLAB error.

HI all, I am getting the following error while setting up the Pluto-SDR, in MATLAB Communication Toolbox Support Package. Any suggestions or comments, will be much appreciated.

Parents
  • Try reinstalling the support package as suggested.

    -Travis

  • Did you mean Communication Toolbox support package or LibIIO?

    Note: I am using MATLAB 2019a.

  • Communication Toolbox Support Package For ADALM-PLUTO.

    -Travis

  • I have tested by reinstalling the package. Actually. the package installed successfully. But when I go to hardware setup from the package (as shown in the fig. above), then it show the message "The libiio installation directory was not found. Try reinstalling the support package."

    I'm using Windows 10 and the firmware version of Pluto is v0.31.

    I am running the support package installer with MATLAB run as administrator.

    I have tested with command prompt by running "iio_info.exe -s". It returns Pluto's serial and some other information.

    I have tested the following in the MATLAB command line.

    rx = sdrrx('Pluto','RadioID','ip:192.168.2.1')

    rx()

    It gives me the following error:

    ====================

    Error using matlabshared.libiio.internal.getHostInstDir

    The libiio installation directory was not found. Try reinstalling the support package.

    Error in matlabshared.libiio.internal.loadLibrary

    Error in matlabshared.libiio.base/loadLib

    Error in matlabshared.libiio.base/setupLib

    Error in matlabshared.libiio.base/setupImpl

    Error in comm.libiio.AD9361.base/setupImpl

    Error in comm.libiio.AD9361.rx/setupImpl

    Error in comm.plutoradio.rx/setupImpl

    Error in comm.SDRRxPluto/setupImpl

    =======================

    Please help.

Reply
  • I have tested by reinstalling the package. Actually. the package installed successfully. But when I go to hardware setup from the package (as shown in the fig. above), then it show the message "The libiio installation directory was not found. Try reinstalling the support package."

    I'm using Windows 10 and the firmware version of Pluto is v0.31.

    I am running the support package installer with MATLAB run as administrator.

    I have tested with command prompt by running "iio_info.exe -s". It returns Pluto's serial and some other information.

    I have tested the following in the MATLAB command line.

    rx = sdrrx('Pluto','RadioID','ip:192.168.2.1')

    rx()

    It gives me the following error:

    ====================

    Error using matlabshared.libiio.internal.getHostInstDir

    The libiio installation directory was not found. Try reinstalling the support package.

    Error in matlabshared.libiio.internal.loadLibrary

    Error in matlabshared.libiio.base/loadLib

    Error in matlabshared.libiio.base/setupLib

    Error in matlabshared.libiio.base/setupImpl

    Error in comm.libiio.AD9361.base/setupImpl

    Error in comm.libiio.AD9361.rx/setupImpl

    Error in comm.plutoradio.rx/setupImpl

    Error in comm.SDRRxPluto/setupImpl

    =======================

    Please help.

Children