SCOPY not responding

SCOPY on my ADALM2000 has been throwing an error message when trying to launch both the Oscilloscope and Volt Meter.  I'm not have the problem with the Signal Generator.  With the little spinning icon, the error message is "SCOPY not responding."

I uninstalled and reinstalled SCOPY two times but this did not help.  I'm able to connect and calibrate fine.  

Please advise.  Thank you

Parents
  • 0
    •  Analog Employees 
    on Apr 10, 2020 8:41 AM 7 months ago

    Hello, 

    The oscilloscope and voltmeter shouldn't run at the same time, however, the application shouldn't crash. Do you have any steps to reproduce this issue ? What version of software/firmware are you running ?

    -Adrian

  • Adrian, 

    After re-installing SCOPY from the wiki link (latest Windows release - see picture), SCOPY connects and calibrates fine.  Signal generator launches fine too.  When I launch Oscilloscope, "Not responding) message (see picture).  I am also not able to X out of SCOPY and must use Task Manager to shut down SCOPY.  I'm using Windows 10.   

    I'm a beginner and have built a few simple circuits following GREAT COURSES, Modern Electronics lecture series.  These include an amp built with transistors, a battery tester using an integrate amp chip and an attempt at a two stage transistor amp.  Sometimes I use the SCOPY Power Supply.  Sometimes I use AA batteries to get up to 10 volts + and 10 volts, as called for in the diagrams on GREAT COURSES.  With that voltage, I smoked transistors on two occasions.  An electrical engineer friend advised to use less voltage and throw in an additional resistors to protect transistors and I've been using 4.5 volts or so.  As a side note, I'm also connecting all of the grounds/ reference grounds of my AA batteries with the SCOPY ground leads.      

    Once I get a circuit wired up, powered up, I then start sampling voltages using my separate multi-meter and also the Oscilloscope probes to see the input and output.  I usually fail the first time so, to confirm the Signal Generator is working I've connected those leads direct to the Oscilloscope leads to confirm I'm getting signal.  Some trial and error.  

    Question - is the ADALM2000 designed to be protected by mistakes that a beginner might make?  Aka, smoking transistors, connect Signal Generator leads direct to Oscilloscope (I've learned maybe one should always have a load/ resistor when doing this.)  I haven't seen any visible/ physical signs of this looking at the ADALM2000 unit - aka, blue lights still on.  

    See two pictures (attached).  

    Thank you, 

    Greg 

     

Reply
  • Adrian, 

    After re-installing SCOPY from the wiki link (latest Windows release - see picture), SCOPY connects and calibrates fine.  Signal generator launches fine too.  When I launch Oscilloscope, "Not responding) message (see picture).  I am also not able to X out of SCOPY and must use Task Manager to shut down SCOPY.  I'm using Windows 10.   

    I'm a beginner and have built a few simple circuits following GREAT COURSES, Modern Electronics lecture series.  These include an amp built with transistors, a battery tester using an integrate amp chip and an attempt at a two stage transistor amp.  Sometimes I use the SCOPY Power Supply.  Sometimes I use AA batteries to get up to 10 volts + and 10 volts, as called for in the diagrams on GREAT COURSES.  With that voltage, I smoked transistors on two occasions.  An electrical engineer friend advised to use less voltage and throw in an additional resistors to protect transistors and I've been using 4.5 volts or so.  As a side note, I'm also connecting all of the grounds/ reference grounds of my AA batteries with the SCOPY ground leads.      

    Once I get a circuit wired up, powered up, I then start sampling voltages using my separate multi-meter and also the Oscilloscope probes to see the input and output.  I usually fail the first time so, to confirm the Signal Generator is working I've connected those leads direct to the Oscilloscope leads to confirm I'm getting signal.  Some trial and error.  

    Question - is the ADALM2000 designed to be protected by mistakes that a beginner might make?  Aka, smoking transistors, connect Signal Generator leads direct to Oscilloscope (I've learned maybe one should always have a load/ resistor when doing this.)  I haven't seen any visible/ physical signs of this looking at the ADALM2000 unit - aka, blue lights still on.  

    See two pictures (attached).  

    Thank you, 

    Greg 

     

Children