Can't install Scopy Application on Raspberry Pi 3 Model B

I've tried installing (on and off for like 2 months now) the Scopy flatpak app on a Raspberry Pi 3, using ArchLinux Arm, Ubuntu MATE, Rasbian Jessie , and Raspbian Buster.

All times I got the same result where I follow all the instructions, the installation completes, but when I try to run the app from CLI I get the error:

kelv@kelv-desktop:~$ flatpak run org.adi.Scopy

bwrap: execvp ldconfig: Exec format error

error: ldconfig failed, exit status 256

When trying to build Scopy using the step-by-step instructions (on all the above listed distros), I get a variety of errors where some dependencies are not present near the end of the installation process. I tried making a .sh script to run the installation from start to finish, but I'd rather try and get the flatpak installation working.

Does anyone have an idea to how I can get this to install?

Thanks in advance!



Added thanks
[edited by: KBoateng57 at 4:06 AM (GMT 0) on 13 Aug 2019]