Post Go back to editing

Re: ADALM1000 doesn't turn on after attempted firmware update

Hi dmercer,

I'm having a similar problem with my ADALM1000 except I'm not seeing any signs that Windows is detecting it and BOSSA isn't picking it up either. However, instead of having a failed update using Pixelpulse, I used BOSSA to start. Following the instructions, I put the device into reset mode but BOSSA still didn't pick it up (this was on a Mac). Prior to the attempt, alice was not detecting the device either (on the same Mac). I've tried switching it to a few different computers now (including a Windows computer with Pixelpulse and BOSSA) but none of them have detected the board. Any suggestions?



  • Noah:

    On a Windows machine - plug it in, and see what is comes up in device manager. It should be a comm port. If it doesn't let me know.

    - Robin

  • Hi Robin,

    Thanks for the fast reply. I just plugged it into the same Windows laptop and it worked perfectly. I didn't change anything, in fact both devices sat untouched and unplugged overnight. I'm wondering if my board got stuck while loading the bootloader for some reason and just needed to completely reset by letting it discharge overnight.

    The boot problem is fixed and new firmware is installed.

    However the alice software on the Mac still says that there is no device plugged in. Any ideas? I'm running alice 1.0.



  • Actually correction. Some tools in the alice suite are working. The ones I've tested like the ohm meter and the voltage meter work just fine. But the oscilloscope does not.

  • The scope, spectrum analyzer, and impedance analyzer all need the Python numpy module to be installed.