accessing the PIO pins on the ADALM1000

Hi,
I am a professor of physics at the University of Maryland.  Professor Linke and I are using the ADALM1000 to teach an online electronics course this fall.  I have been working through your lovely list of labs at: https://wiki.analog.com/university/courses/alm1k/alm_circuits_lab_outline

In lab https://wiki.analog.com/university/courses/alm1k/alm-lab-1 for the summing circuit, the POI digital outputs are used.  I see from searching on this forum that there is a stand alone python script available to set these.  But is there a way to set them using the ALICE suite that is used for the rest of the exercises?


Best
Sarah Eno
Professor, Physics, U. Maryland

    •  Analog Employees 
    on Jul 24, 2020 8:17 PM 4 months ago

    Hi:

    If the static Digital output controls are enabled in the alice_init.ini file then you should have a button on the right hand side that opens the screen.

    The line to enable the digital i/o needs to look like this:

    global EnableDigIO; EnableDigIO = 1

    I was going to include an image of what it looks like but EZ is not letting me include an image for some reason???

    Doug

  • Thanks.  When I look at my alice_init.ini, it doesn't have that line.  But it does have

    "global EnablePIODACMode; EnablePIODACMOde =0".

    Is this the one I should change instead?

    •  Analog Employees 
    on Jul 28, 2020 12:44 AM 3 months ago in reply to Sarah Eno

    Are you using the most recent release of the Windows installer (1.3.7)

    https://github.com/analogdevicesinc/alice/releases/tag/1.3.7

    There were changes to make all the buttons to open / enable the virtual instruments optional. That is they have switches in the alice_init.ini file.

    The latest release should have the static digital pin controls enabled.

    As to the your present init file which looks like it is from an older release, The EnablePIODACMode switch is for a different use of the digital pins.

    Previous versions might have not had a switch for the static digital controls i.e there no matter what.

    Either way uninstall the version you are using and install 1.3.7

    Thanks

    Doug